Identification

Identifiant
Mot de passe
Mot de passe oublié ?

Partage de documents

Cours



Sondage

Quelle est votre profession ?
Etudiant / Elève
Enseignant / Pédagogue
Webmestre / Développeur
Journaliste / Blogueur
Autre
 
Comment trouvez-vous le système Manhali ?
Très utile
Utile
Peu utile
Inutile

  
 

Chapitre précédent
Chapitre suivant
Structures de contrôle de base
Informations sur le chapitre :
Cours : Algorithmique
 
elhaddioui_ismail
  • Auteur : elhaddioui_ismail
  • Créé le : 20/04/2014 - 22:30
  • E-mail : ismail.elhaddioui
  • Modifié le : 27/04/2014 - 15:48
  • Lu : 9584 fois
  • Réponses correctes d'auto-évaluation : 41.53 %
  • Licence : BY(Paternité) - NC(Pas d'Utilisation Commerciale) - ND(Pas de Modification)
  • Note : 1/62/63/64/65/66/6 (1 Votes : 6/6)
  •  
    Objectifs du chapitre :

    Savoir utiliser la structure sélective

    • Introduction

    • En algorithmique, les opérations élémentaires relatives à la résolution des problèmes peuvent être organisées suivant trois familles de structures algorithmiques fondamentales :

      - Structure séquentielle ou linéaire ;

      - Structure sélective ou conditionnelle ;

      - Structure itératives ou répétitive.

      • Structure séquentielle

      Dans une structure séquentielle, les instructions sont exécutées l'une après l'autre de façon que :

      1. L'ordre des instructions est respecté
      2. Aucune instruction n'est omise

      La structure séquentielle est la structure la plus simple que l'on puisse trouver dans un algorithme.

      • Structure sélective

      Dans les exercices qu’on a déjà vus, nous avons utilisé seulement la structure séquentielle. Cette structure ne va pas être utile dans le cas où nous avons plusieurs choix possibles. Par exemple, si on veut calculer le résultat de la division de deux nombres, on doit impérativement tester si le deuxième nombre est diffèrent de 0 afin que le résultat soit correct.

    • Structure sélective (Si)

      • Structure sélective simple
      • Définition

      La structure sélective permet d'exécuter des instructions en fonction de réponses à des conditions.

      • Format général

      Si  (condition)  Alors

              instruction 1 ;

              instruction 2 ;

      FinSi ;

      • Exercice 5 :

      - Ecrire un algorithme qui permet de calculer le résultat de la division de deux entiers A et B.

      Lien : Correction de l'exercice N° 5

      • Structure alternative
      • Définition

      Une structure alternative est une situation dans laquelle on ne peut choisir que deux solutions possibles.

      • Format général

      Si  (condition)  Alors

               instruction 1 ;

               instruction 2 ;

      Sinon

               instruction 3 ;

               instruction 4 ;

      FinSi ;

      • Exercice 6 :

      - Ecrire un algorithme qui lit deux entiers A et B, et affiche le plus grand.

      Lien : Correction de l'exercice N° 6

      • Exercice 7 :

      - Ecrire un algorithme qui lit trois entiers A, B et C, et affiche le plus grand.

      Lien : Correction de l'exercice N° 7

      • Structure alternative imbriquée
      • Définition

      La structure alternative imbriquée est une structure utilisée lorsqu'on a plus de deux cas possibles

      • Format général

      Si (condition 1) Alors

           Si (condition 2) Alors

      instruction 1 ;

           Sinon

      instruction 2 ;

           FinSi ;

      Sinon

           Si (condition 3) Alors

      instruction 3 ;

           Sinon

      instruction 4 ;

           FinSi ;

      FinSi ;

      • Exercice 8 :

      Ecrire un algorithme qui donne l’état de l’eau selon sa température :

      - Si T < 0 : état solide.

      - Si T > 100 : état gazeux.

      - Si 0 < T < 100 : état liquide.

      Lien : Correction de l'exercice N° 8

      • Exercice 9 :

      Ecrire un algorithme qui donne la mention selon la moyenne générale obtenue par un élève :

      - Si moyenne < 10 : Insuffisant

      - Si 10 < moyenne < 12 : Passable

      - Si 12 < moyenne < 14 : Assez bien

      - Si 14 < moyenne < 16 : Bien

      - Si moyenne > 16 : Très bien

      Lien : Correction de l'exercice N° 9

    • Structure sélective à choix multiples (Selon que)

      • Définition

      La structure à choix multiples est utilisée lorsque plusieurs conditions portant sur la même variable s'enchaînent

      • Format général

      Selon que variable vaut

      Valeur 1 : instruction 1 ;

      Valeur 2 : instruction 2 ;

      Sinon : instruction 3 ;

      FinSelon ;

      • Remarque

      L'instruction Sinon est facultative, dont l'action sera exécutée si aucune des conditions évaluées n'a été remplie

      • Exercice 10 :

      Ecrire un algorithme qui affiche selon un numéro compris entre 1 et 12 le mois équivalent

      Lien : Correction de l'exercice N° 10


    1. Quel est le résultat de la séquence d'instructions suivante ?

      X ← 1 ;
      Y ← 3 ;
      Z ← 0 ;
      Si (X > Y) Alors
           X ← 5 ;
      Sinon
           Si (X > 0) Alors
                X ← -1 ;
           Sinon
                X ← 4 ;
           FinSi ;
      FinSi ;
      Si (X > Z) Alors
           X ← 2 ;
      Sinon
           X ← 3 ;
      FinSi ;

    2. X = -1
      X = 1
      X = 2
      X = 3
      X = 4
      X = 5

    3. Laquelle des structures suivantes est correcte ?

    4. Si (condition) Alors instruction 1 ; instruction 2 ; FinSi ;
      Si (condition) instruction 1 ; Sinon instruction 2 ; FinSi ;
      Si (condition) Alors instruction 1 ; Sinon instruction 2 ;

    Chapitre précédent
    Chapitre suivant

     
    InfoNuls 2010-2015 - Powered by Manhali