Identification

Identifiant
Mot de passe
Mot de passe oublié ?

Partage de documents

Cours



Sondage

Quelle est votre profession ?
Etudiant / Elève
Enseignant / Pédagogue
Webmestre / Développeur
Journaliste / Blogueur
Autre
 
Comment trouvez-vous le système Manhali ?
Très utile
Utile
Peu utile
Inutile

  
 

Chapitre précédent
Chapitre suivant
Les itérations (structure répétitive)
Informations sur le chapitre :
Cours : Algorithmique
 
elhaddioui_ismail
  • Auteur : elhaddioui_ismail
  • Créé le : 20/04/2014 - 22:52
  • E-mail : ismail.elhaddioui
  • Modifié le : 27/04/2014 - 15:49
  • Lu : 5689 fois
  • Réponses correctes d'auto-évaluation : 46.11 %
  • Licence : BY(Paternité) - NC(Pas d'Utilisation Commerciale) - ND(Pas de Modification)
  • Note : 1/62/63/64/65/66/6 (2 Votes : 6/6)
  •  
    Objectifs du chapitre :

    Savoir utiliser la structure répétitive

    • Introduction

    • L'itération permet d'exécuter plusieurs fois une suite d'instructions.

      Il existe deux grandes catégories d'itérations :

      • Les itérations déterministes : le nombre d'itérations est défini a l'entrée de la boucle
      • Les itérations indéterministes : l'exécution de la prochaine itération est conditionnée par une expression booléenne

       

    • Les itérations déterministes (pour)

    • Il existe une seule instruction permettant de faire des boucles déterministes, c'est l'instruction pour

      • Syntaxe :

      Pour (variable  valeur_début à valeur_fin) faire

      instructions…

      FinPour ;

      Dans ce cas, la variable utilisée prend successivement les valeurs comprises entre valeur de début et valeur de fin

      • Exercice 11 :

      Ecrire un algorithme qui demande un entier de départ, et qui ensuite affiche les dix nombres suivants. Par exemple, si l'utilisateur entre le nombre 17, le programme affichera les nombres de 18 à 27.

      Lien : Correction de l'exercice N° 11

      • Exercice 12 :

      Ecrire un algorithme qui demande un entier, et qui calcule la somme des entiers jusqu’à ce nombre. Par exemple, si l’on entre 5, le programme doit calculer : 1 + 2 + 3 + 4 + 5 = 15

      Lien : Correction de l'exercice N° 12

    • Les itérations indéterministes (tant que, répéter jusqu’à)

      • Tant que :

      L'instruction "Tant que" permet d'exécuter des instructions tant que l'expression booléenne est vraie.

      • Syntaxe :

      Tant que (condition) faire

                  Instructions…;

      FinTantque ;

      • Répéter jusqu'à :

      L'instruction "Répéter jusqu'à" permet d'exécuter des instructions jusqu'à ce que l'expression booléenne est vraie.

      • Syntaxe :

      Répéter

                  Instructions…;

      Jusqu'à (condition) ;

      • Remarque :

      A la différence de l'instruction tant que, dans l'instruction "répéter jusqu'à"  les instructions sont exécutées au moins une fois.

      • Exercice 13 :

      Ecrire un algorithme qui calcule le Plus grand commun diviseur "PGCD" de deux entiers à l'aide de l'algorithme d'Euclide (exemple A = 12 et B = 8, Alors PGCD = 4)

      Lien : Correction de l'exercice N° 13


    1. Quelle est la valeur de « n » après l'exécution de ces boucles imbriquées :

      n ← 3 ;

      Pour (i ← 1 à 3) faire

      Pour (j ← 1 à 3) faire

      n ← n + 1 ;

      FinPour ;

      FinPour ;

    2. n = 3
      n = 9
      n = 10
      n = 11
      n = 12

    3. Combien de fois, la boucle suivante va être exécutée ?

      i ← 0 ;

      Répéter

      Ecrire (i) ;

      Jusqu'à (i > 0) ;

    4. 0 fois
      1 fois
      Boucle infinie

    5. Combien de fois, la boucle suivante va être exécutée ?

      i ← 0 ;

      Tant que (i > 0) faire

      Ecrire (i) ;

      FinTantque ;

    6. 0 fois
      1 fois
      Boucle infinie

    Chapitre précédent
    Chapitre suivant

     
    InfoNuls 2010-2015 - Powered by Manhali